shiny.semantic: 'FomanticUI' Support for Shiny

Creating a great user interface for your Shiny apps can be a hassle, especially if you want to work purely in R and don't want to use, for instance HTML templates. This package adds support for a powerful UI library 'FomanticUI' - <https://fomantic-ui.com/> (before: Semantic). It also supports universal UI input binding that works with various DOM elements.

Version: 0.4.0
Imports: shiny (≥ 0.12.1), htmltools (≥ 0.2.6), htmlwidgets (≥ 0.8), purrr (≥ 0.2.2), stats, magrittr, jsonlite, glue, R6
Suggests: dplyr, tibble, knitr, testthat, lintr, DT, covr
Published: 2020-09-07
Author: Filip Stachura [aut], Dominik Krzeminski [cre], Krystian Igras [aut], Adam Forys [aut], Paweł Przytuła [aut], Jakub Chojna [aut], Olga Mierzwa-Sulima [aut], Ashley Baldry [ctb], Jakub Chojna [ctb], Olga Mierzwa-Sulima [ctb], Pedro Manuel Coutinho da Silva [ctb], Paweł Przytuła [ctb], Kamil Żyła [ctb], Appsilon Sp. z o.o. [cph]
Maintainer: Dominik Krzeminski <dominik at appsilon.com>
BugReports: https://github.com/Appsilon/shiny.semantic/issues
License: MIT + file LICENSE
NeedsCompilation: no
CRAN checks: shiny.semantic results

Downloads:

Reference manual: shiny.semantic.pdf
Package source: shiny.semantic_0.4.0.tar.gz
Windows binaries: r-devel: shiny.semantic_0.4.0.zip, r-release: shiny.semantic_0.4.0.zip, r-oldrel: shiny.semantic_0.4.0.zip
macOS binaries: r-release: shiny.semantic_0.4.0.tgz, r-oldrel: shiny.semantic_0.4.0.tgz
Old sources: shiny.semantic archive

Reverse dependencies:

Reverse imports: semantic.dashboard

Linking:

Please use the canonical form https://CRAN.R-project.org/package=shiny.semantic to link to this page.